Introduction
This document provides steps required to
clone Oracle EBS R 12.1.2 in Sun Solaris environment. This document has been
designed to perform EBS Cloning in multi user environment. Before the startup
of Clone Process on Target System it must be ensured that PreClone steps have
been performed on the Source System.
Preclone Steps
on Database Tier
bash-3.00$ pwd
/u1/oradev/DEV/db/tech_st/11.1.0/appsutil/clone/bin
bash-3.00$ perl adcfgclone.pl dbTier
Preclone Steps
on Application Tier
bash-3.00$ pwd
/u1/appdev/DEV/inst/apps/DEV_crpamc/admin/scripts
bash-3.00$ perl adpreclone.pl appsTier
After these two PreClone steps and shutdown
of Application and Database Tier, TAR files should be generated and moved to
Target System
Operating System Prerequisites before Cloning Process Startup
OS Properties Verification
hostname - Command to verify hostname of
target machine
You might need to update /etc/hosts file to
include hostname if it is not already set
cat /etc/hosts
127.0.0.1 localhost
::1 localhost
10.10.0.165 CRPEME.inboxbizx.com CRPEME
cat /etc/netmasks - Command to verify net masks
settings
uname –a - Command to verify OS version
df –lh - Command to verify available space
OS Patches Verification
showrev –p | sort >> patchList - This
command will generate a file named patchList in which you need to search and
confirm that following four packages are available in OS environment.
125100
120473
127111
137111
OS Packages Setup
Confirm following OS packages are installed.
pkginfo
SUNWarc
pkginfo
SUNWbtool
pkginfo
SUNWhea
pkginfo
SUNWlibm
pkginfo
SUNWlibms
pkginfo
SUNWsprot
pkginfo
SUNWtoo
pkginfo
SUNWi1of
pkginfo
SUNWi1cs
pkginfo
SUNWi15cs
pkginfo
SUNWxwfnt
pkginfo
SUNWuiu8
pkginfo
SUNWulcf
pkginfo
SUNWlibC
Prerequisite s Software
which ar
which ld
which make
which X
ROOT user profile settings
Insert line below in .profile file of root
user so that software installed could be confirmed,
PATH=$PATH:/usr/sbin:/usr/bin:/usr/X11/bin:/usr/local/bin:/usr/ccs/bin:/usr/openwin/bin:/usr/dt/bin:/usr/sfw/bin
export PATH
OS Kernel Settings
Insert following line in /etc/system file
set noexec_user_stack=1
OS Groups Settings
groupadd oinstall
groupadd dba
Home Directories Creation
mkdir /export/home
mkdir /export/home/oraeme
mkdir /export/home/appeme
OS Users Setups
useradd -g oinstall -G dba -d /export/home/oraeme/ oraeme
useradd -g oinstall -G dba -d /export/home/appeme/ appeme
cp .profile /export/home/oraeme/
cp .profile /export/home/appeme/
chown oraeme:oinstall
/export/home/oraeme/.profile
chown appeme:oinstall
/export/home/appeme/.profile
Folders Creation and Rights Setup
mkdir /u1/oraeme
mkdir /u1/appeme
chown -Rh oraeme:oinstall
/u1/oraeme/
chown -Rh appeme:oinstall
/u1/appeme/
chmod -fR 775 /u1/oraeme/
chmod -fR 775 /u1/appeme/
mkdir /var/tmp/.oracle
chmod 777 /var/tmp/.oracle
OS Project Initiation
projadd -U oraeme user.oraeme
projmod -s -K
"project.max-sem-ids=(priv,100,deny)" user.oraeme
projmod -s -K
"process.max-sem-nsems=(priv,256,deny)" user.oraeme
projmod -s -K
"project.max-shm-memory=(priv,23622320128,deny)" user.oraeme
projmod -s -K "project.max-shm-ids=(priv,100,deny)"
user.oraeme
projmod -s -K
"process.max-file-descriptor=(priv,65536,deny)" user.oraeme
Update /etc/user_attr file to include following line
oraeme::::project=user.oraeme
Verify that project has been added,
cat /etc/project
Installation Process
Mount the stage,
mount 10.10.0.89:/u2/StageR12/ /mnt/EBS
Login as root user and go to stage
directory,
cd /mnt/EBS/startCD/Disk1/rapidwiz
./rapidwiz
Screen 1
Screen 2
Screen 3
Screen 4
Screen 5
Screen 6
Make Sure the port number is set to default
Screen 7
Screen 8
Screen 9
Screen 10
Screen 11
Screen 12
Screen 13
Screen 14
Screen 15
Screen 16
Screen 17
Screen 18
Path Setting:
Put env path <context-filename>.env into
.profile for oraamc
Put env path <context-filename>.env into
.profile for appamc
SPFile Enabling
Check if spfile is being used or not using following
commands
slqplus / as sysdba
show parameter spfile
If it is not being used you can create it using
following command,
create spfile from pfile;
Then you can remove pfile
rm $ORACLE_HOME/dbs/initDEV.ora
Automatic Memory Management Configuration
alter system set sga_max_size=0 scope=spfile;
alter system set sga_target=0 scope=spfile;
alter system set memory_max_target=16G scope=spfile;
alter system set memory_target=14G scope=spfile;
alter system set pga_aggregate_target=0 scope=spfile;
alter system set sga_target=0 scope=spfile;
With root user:
1. cd $ORACLE_HOME/bin
2. chmod 4550 oradism
3. chmod g+s oradism
4. chown root:dba oradism
5. Bounce the database
With oracle user:
cd $ORACLE_HOME/appsutil/scripts/<context dir>
vi adstrtdb.sql
Remarks the startup entry
Just write startup
Save and exit
No comments:
Post a Comment